Veeam Endpoint Backup: error: Cannot find partition

Veeam Endpoint Backup: error: Cannot find partition

Today i had to do some quick research for a specific problem in Veeam Endpoint Backup FREE. The program told me that it cannot find a specific partition on my computer. The first thought was that this could be a bad sign, a sign of a predictive drive error or some thing like that. My spider senses were tingeling…

My computer is setup to do a daily backup to a Synology NAS system with Veeam Endpoint Backup FREE. It does it’s job very fast and really good. It was an easy and straight forward setup process. The guys at Veeam did an excellent job with this piece of software (as they also did for the commercial Veeam Backup & Replication, just to make that clear).

So i was sitting in front of my screen looking at this error message. First of all i did a quick look in Windows disk management and it told me that my disks were all present and accessible. So i did not check SMART nor executed other hard disk tests. A quick hip shot at Google brought me to the solution. And as often i found the solution in the famous Veeam forums.

When i find the time i will do further research about the root cause of this problem. But i think i already have something a possible cause discovered (upgrading to the latest Windows 10 Insider Slow Ring update)… But anyway.

The problem

Error: Cannot find partition \\?\GLOBALROOT\Device\Harddisk3\Partition2

Veeam Endpoint Backup - Error message
Veeam Endpoint Backup – Error message

That sounds bad in the first moment. But if you check your disks, and they are all present and accessible, than it shouldn’t be a big problem.

The solution

It was really easy. But you have to have the idea were to look for the solution. Or you should know the root cause of this problem.

Finally, the solution was to re-run the “Configure backup” wizard. At the point where you select the volumes for backup, mark the checkbox for “Show system and hidden volumes”. That did the trick. My “EFI system partition” was deselected, so i had to reselect it. After checking the volumes (and marking the missing ones) you can finish the wizard.

Veeam Endpoint Backup - Choose volumes
Veeam Endpoint Backup – Choose volumes

After this quick fix my backup went smoothly and my computer is now safe again…

Veeam Endpoint Backup - Backup completed successfully
Veeam Endpoint Backup – Backup completed successfully

If this post helped you solving the problem, just leave me a comment. Thanks 😉