VMware vSphere Homelab: Die erste VM läuft im PoC

Heute Abend habe ich endlich wieder Zeit gefunden um mich um meinen Proof of Concept (PoC) zu kümmern. Wie vor einiger Zeit angekündigt arbeite ich derzeit an einem PoC für mein Homelab. Das Ziel des Homelab ist eine Anzahl an nested ESXi auf einem physischen ESXi zu installieren, und ganz oben drauf, auf den nested ESXi, einige VMs zu Testzwecken einzurichten. Schlussendlich soll mir das Homelab zum besseren Verständnis der VMware Technologien und zur Vorbereitung auf Zertifizierungsprüfungen dienen. Da noch nicht die gesamte Hardware bei mir ist (eine gute Basis ist sehr wohl vorhanden, es fehlen aber noch verschiedene Komponenten) musste ich mich etwas einschränken. Im Blogpost über die ersten Gehversuche im Homelab habe ich die ersten Schritte erklärt.

Nun habe ich heute Abend also meine erste VM innerhalb des PoC Homelabs, also dem ESXi Cluster mit VSAN, eingerichtet und installiert. Es war zu Beginn etwas mühsam. Ich bin auf das eine oder andere Problem gestossen welches ich lösen musste. Angefangen bei der VM-Konsole, über das Mounten des ISO-Images für das Betriebssystem bis hin zu DNS.

Problem 1 – PoC und die Eingabegeräte

Besonders mühsam war die VM-Konsole, also der „Bildschirm“ über welchen ich die VM anschauen und bedienen kann. Mit vSphere 6 läuft der vSphere Web Client richtig gut. Ich habe im ersten Moment gar nicht daran gedacht den C# Client (Fat Client) zu installieren. Die Performance des Web Client ist toll, ein riesiger Sprung im Vergleich zu dessen Vorgängerversionen. Jedoch ist es so eine Sache mit der VM-Konsole in der HTML5 Oberfläche im Browser. Die Tastatur hat funktioniert, auch klicken mit der Maus war drin, aber den Cursor konnte ich nicht bewegen. Ich denke da herrscht noch Nachholbedarf seitens VMware. So musste ich dennoch den VMware vSphere Client herunterladen und installieren und konnte dann über diesen bequem die VM-Konsole starten.

Problem 2 – ISO-Image in den Datastore laden

Zugegeben, dieses Problem ist noch nicht gelöst. Aufgrund der nichtssagenden Fehlermeldung konnte ich hier auf die Schnelle keine Lösung finden. Es war nicht möglich via Browser (HTML5 Web Client) ein ISO-File in den VSAN Datastore hochzuladen, um dies dann bspw. für die Installation einer VM zu nutzen. Also musste ich das ISO-Image beim virtuellen (nested) ESXi einbinden und durchreichen. Das ist sicher nicht der übliche Weg, aber er hat funktioniert. Und nur für den PoC reichts allemal. Aber ich suche noch nach einer Lösung für dieses Problem.

Problem 3 – DNS, DNS, DNS…

Wenn es in einem Netzwerk zu irgendwelchen Problemen kommt, ist das wohl einer der ersten Punkte den man prüft. DNS. Kann ich den Hostnamen pingen? Wird der Hostname korrekt in eine IP-Adresse aufgelöst? Funktioniert das ganze auch zurück?

"Unable to connect to the MKS: Login (username / password) incorrect"

Das war die Fehlermeldung wenn ich die VM-Konsole starten wollte. Ein erster Ansatz war eine Konfigurationsdatei von VMware Workstation anzupassen und dort drin den „authd.client.port“ auf Port 902 zu stellen (war bei mir 903). Anschliessend noch den „VMware Authorization Service“ sowie den „VMware Workstation Server“ neustarten, dann sollte es gehen. Sollte. Ging aber nicht. Also weitergrübeln und suchen. Ich fand einen Beitrag in der VMware Community der schlussendlich zur Lösung half. Anscheinend sind gewisse VMware Dienste / Programme heikel was DNS angeht. Wenn DNS nicht sauber funktioniert, funktionieren auch bestimmte Dinge bei VMware nicht. So konnte ich mich bspw. über die IP-Adresse der vCenter Server Appliance mit dem vSphere Client anmelden. Sobald ich aber die VM-Konsole öffnen wollte, erschien obige Fehlermeldung.

Sodann habe ich auf meinem Rechner das Hosts-File gesucht und die notwendigen Einträge gemacht. Anschliessend habe ich mich über den FQDN der vCenter Server Appliance mit dem vSphere Client verbunden und konnte erfolgreich die VM-Konsole starten.

Ach ja, so sieht sie aus, die erste VM im PoC Homelab…

Kommentar verfassen